B19: gcc -r option broken?

Greg Humphreys greg@ahpah.com
Thu Sep 3 17:23:00 GMT 1998


I'm trying to use the -r option for gcc to generate an executable
with relocation information in it.  It appears to be broken.

When I run the resulting .exe, I get "This program cannot be run in
DOS mode".  Every PE viewer I have dies a miserable flaming death on
the resulting .exe (I've tried three of them, including one I wrote
myself).

It looks to me that the section headers are messed up (they have very
large values for the section sizes), which makes the file impossible
to parse (this is my initial assessment after looking at my own
PE parser in a debugger).  The fact that the stub program is being 
run by Windows is even more confusing.

I really need to be able to include relocation information in my
executables, and I'd like to continue to use gcc.

I'm running Windows 98.  

Any help on this matter would be greatly appreciated.

---
And the wind cried... HUMPER. (greg@ahpah.com) 
-
For help on using this list (especially unsubscribing), send a message to
"gnu-win32-request@cygnus.com" with one line of text: "help".



More information about the Cygwin mailing list