CRLF in cat output breaks scripts.
Thu Sep 10 21:27:00 GMT 1998

I must be missing something!  

cat and other commands that use > to write files, put in CR's so that
we end up with CRLF at the end of every line.

This means that shell scripts that are generated by make, configure,
or other shell scripts end up with CRLF line endings, and don't run
under bash (or ash).  In addition, autoconfig turns a perfectly good
template into a configure script full of ^Ms.  

The only way I've found to get rid of these is editing with vim.
Probably a perl script will work as well, but haven't tried this yet.

The major cygwin porters must have a way around this ...?

Here is my mount output:

bash-2.01$ mount
Device           Directory           Type        Flags
C:\DATA\0058744\non-cyg /non-cyg            native      text!=binary
\\.\tape1:       /dev/st1            native      text!=binary
\\.\tape0:       /dev/st0            native      text!=binary
\\.\b:           /dev/fd1            native      text!=binary
\\.\a:           /dev/fd0            native      text!=binary
C:\\DATA\\0058744\\cygnus /                   native      text=binary
(non-cyg is where I've kept some applications that were not cygwin,
like MikTeX, NTemacs.  Probably I didn't need to do that, but when I
was starting out with cygwin ....)

I'm using B19.3 (coolview), the bash  and tools that came with the 
cygwin full distribution, egcs - last weeks version -- on NT4.0SP3.

I just retested GNU's 'hello' to see if I'd messed up something
fundamental since things worked -  It still configures, compiles, and
installs out of the box.  Of course it doesn't try to write any shell 
scripts that are essential to its own process, like some programs do.


John Velman  

For help on using this list (especially unsubscribing), send a message to
"" with one line of text: "help".

More information about the Cygwin mailing list