FWD: PROBLEM WITH DU -Reply

tprince@cat.e-mail.com tprince@cat.e-mail.com
Mon Sep 21 22:08:00 GMT 1998


I too am running on NT4/SP3.  For me, du has no trouble with the
Winnt directories, which are installed on //c.  However,
the command

du //d

processes only the first folder correctly, and fails as you
describe.  I am using B19.1/new-cygwinb19.dll, as I have not
been able to connect to the Okhapkin site from the office,
together with bash from cdk.exe.   Perhaps we should try this
again with coolview.

I don't reproduce the problem you describe with du failing to read
the starting directory path.

"On NT Server 4SP3+some hotfixes, the following occurs when
executing du:
Only the size of the first few directores are displayed. For the rest
of
them, du says "du: d:\/WINNT: No such file or directory" although
the first
ones have been shown correctly. The command "du" has been
run from 4nt shell,
not bash. I have not tested under bash. Under NT's cmd.exe the
result is
identical. If the first directories encountered contain
subdirectories they
will be displayed correctly.
  I have tried to give du parameters in DOS (\) and unix (/)
fashions but
none works. Moreover, if I run "du ..", "du ../" or "du ..\" it will show
the
usage of the current (!!!) directory alone. "

Dr. Timothy C. Prince
Consulting Engineer
Solar Turbines, a Caterpillar Company
alternate e-mail: tprince@computer.org

           To:                                              INTERNET - IBMMAIL
                                                            I5716149 - IBMMAIL
-
For help on using this list (especially unsubscribing), send a message to
"gnu-win32-request@cygnus.com" with one line of text: "help".



More information about the Cygwin mailing list