Filename problems using Java compiler

John Collins
Wed Feb 17 15:58:00 GMT 1999

When I try to build a java system with cygwin make and jdk1.1.x (x=6,7), I
get failures on each source file of the form
pkg/ Public class pkg.Foo must be defined in a file called
I've been through and solved the classpath problems, I had to use ";"
characters instead of ":", and I had to quote the whole classpath
expression.  I've tried quoting the individual filenames going into javac
with both single and double quotes, and I can't get them to be interpreted
properly.  I get the same error if I just run the win32 javac directly in
bash, so it's not make that's the problem.
Interestingly, I don't have that problem with the Java2 version of javac, so
something has been changed at the java end.  However, for part of what I'm
doing I can't use Java2.
I've been through the FAQ and the mail archives to no avail.  Did I miss
something?  Thanks very much.
John Collins
KeyTech LLC

Want to unsubscribe from this list?
Send a message to

More information about the Cygwin mailing list