tty strangeness and other questions

M Dipperstein
Wed Mar 3 17:21:00 GMT 1999

I've been quietly using Cygwin B20.1 on a windows 95 PC for a few months,
and it's been working pretty much as I expected, except for 3 annoyances
that I haven't been able to resolve.  I've check the archives, and I
haven't found any comments on them, so either I live in my own special
world, or I'm overlooking the obvious.  Any assistance would be

1)  When I set CYGWIN to include the tty option, my A: drive will be
searched for a command before aliases and other parts in my path,
even though A: is not in my path.  This happens when I haven't even
accessed A:. If I remove the tty from the CYGWIN setting, this problem
doesn't happen.  In cygnus.bat, I set my path as follows:
SET PATH=c:\cygnus\cygwin-b20\h-i586-cygwin32\bin;c:\usr\local\bin;%PATH%

which expands to:

and "echo $PATH" shows the following:

Nowhere in there is there an a: or //a.  By the way, why don't I have //c's
in my path?

2)  When I set CYGWIN to include the tty option, using the arrow keys in a
bash console will scroll through my bash command history, but my
command line will not show the command, until I press a displayable key
(I've developed the habit of hitting the space bar).  Similarly, when I
use left and right arrows, I can change my location within the command
line, but the cursor position on my screen does not change.  I've tried it
with TERM set to cygwin, linux, and ansi.sys terminals, and the behavior
doesn't change.

3)  I'm using Michael Hirmke's precompiled ncurses library, and I've
converted the cygwin termcap to a terminfo.  Occasionally (~25% of the
time), when I switch away from my bash console to another windows program,
and back, the ncurses package reports that COLS is 84 instead of 80.
Switching to another window and back will make COLS 80 again.  I'm pretty
sure my cygwin terminfo is okay, because the problem happens when TERM is
set to linux as well.

4)  I'm using Pierre A. Humblet's precompiled man, with Michael Hirmke's
precompiled groff, and the hyphen for words that are split between lines
is displayed as <AD>.  I'm pretty sure this problem is in the latin font
files.  I've tried making character 0255 the hyphen character, but I'm
obviously doing something wrong, because the real hyphen character becomes
<AD> when I make that change.

Thanks in advance for any help, and thanks for all the precompiled
packages, they've saved me all kinds of grief.


Want to unsubscribe from this list?
Send a message to

More information about the Cygwin mailing list