Compiling PM3 Modula-3, worked under B20.0, now hangs "rm", "as", others in infinite loop on B20.1

Parzival Herzog
Wed Mar 31 19:45:00 GMT 1999

....I set this message earlier, but it arrived without a message body, so
here it is again!....

I had used B17 - B19 with no problems for months, Then before I installed
PM3 Modula-3,
I updated to B20.0. PM3 Modula-3 ( ) installed and ran
then I updated to B20.1. PM3 Modula-3 and Cygwin appeared to work fine. Then
I tried
to compile a large Modula-3 package, and after compiling part-way through
system, my computer hung in an infinite loop, steadily allocating about
50-60K of
memory per second, with 100% CPU utilization, and no significant disk
activity. At first
I thought this was a Modula-3 problem, but gradually started to suspect it
was a timing
problem in the Cygwin library. I noticed that the hang occurred after
approximately the
same amount of elapsed time compiling, and not on the same source file, and
exactly the same behaviour while several different programs were active,
i.e. M3cgc1 (the Modula
3 compiler), as (the GNU assembler - called by the compiler), and even once
in "rm" (the Cygwin
rm program, called by make.)

So, I decided to rebuild from scratch the Modula-3 compiler. This failed in
exactly the
same way, with a hang, not always on the same source file, but after roughly
same amount of elapsed time well into a (very complex) build process. I then
uninstalled B20.1, and I went to fetch B20.0, but it was gone from the ftp
(I  guess the "serious bug" fixed in 20.1 caused its withdrawal.) So I
fetched and
re-installed B19.1 Now, Modula-3 installed and ran correctly, and all the
that failed to compile under B20.1, compiled correctly.

Unfortunately, I can't boil this down to a simple isolated case: its not a
program that hangs, but an arbitrary program, and that program is spawned by
a (make-like) shell (m3build) executing a complex build operation. To
the problem you have to install PM3 Modula-3. And in order to do that you
LOTS of disk space (about 400 MB) and you need a patch (at least for the
PM3 1.1.10 version - this may be fixed in the PM3 1.1.11 release - please
contact  . I can say that PM3 Modula-3 is very
reliable very portable software that installs and works on dozens of
machines and
flavours of UNIX, and I hope the Cygnus developers will look into this
problem relatively
quickly, because it seems that a bug has been introduced or unmasked in
form B20.0 to B20.1.

I have a Windows NT 4.0 system, service pack 4, on a 128MB AMD K6-266
I run the NTFS file system, with compression turned on.


Want to unsubscribe from this list?
Send a message to

More information about the Cygwin mailing list