Help! problems running tcl/tk apps

Paul Thiessen paul@grserv.med.jhmi.edu
Sat May 1 07:55:00 GMT 1999


I'm having trouble running C/C++ programs compiled and linked with
cygwin's tcl/tk libraries (I'm using the latest download of the full
cygwin release). The program compiles just fine, but when I run it I get
the errors (shown is the start of a long list of errors) shown below. I've
tried copying the libraries from cygwin's shared/{tcl,tk}8.0/ directories
into one of the directories mentioned below, but to no avail. Where is
this MouseWheel stuff coming from anyway? I don't see it in any of these
tk/tcl library files... Confused.
  Any idea why this is happening or how I can set things up so that it
works properly?
  Thanks,

 - Paul

Errors:

Can't find a usable tk.tcl in the following directories:
    /usr/local/lib/tk8.0 /usr/local/lib/tk8.0 /usr/local/lib/tk8.0
D:/tk8.0 D:/s
hare/tk8.0 D:/library D:/share/tk8.0 D:/tk8.0/library D:/library
/usr/local/tk8.
0/library

/usr/local/lib/tk8.0/tk.tcl: bad event type or keysym "MouseWheel"
bad event type or keysym "MouseWheel"
    while executing
"bind Listbox <MouseWheel> {
%W yview scroll [expr - (%D / 120) * 4] units
}"
    (file "/usr/local/lib/tk8.0/listbox.tcl" line 128)
    invoked from within

... etc, more complaints about MouseWheel ...




-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
  Paul A.   |      paul@grserv.med.jhmi.edu      |  Johns Hopkins
 Thiessen   |  http://grserv.med.jhmi.edu/~paul  |   University
-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-


--
Want to unsubscribe from this list?
Send a message to cygwin-unsubscribe@sourceware.cygnus.com



More information about the Cygwin mailing list