Perl5, cygwin32, administrateur

Rick Saltzman
Thu May 13 00:18:00 GMT 1999

Thanks Sebastien,

I had previously used these instructions but still ended up with the same 
difficulties you, wilson and morlock ran into.  To wit:

Installed cygwin
Read and followed the instructions in:
build-instructions.READFIRST, README.cygwin, build-instructions.charles-wilson

Ran into the following problems:

x2p dependencies do not get made
The build completes
make test fails on file tests (stat) even with CYGWIN=ntea
make install fails because of write permissions

I must emphasize that I used the patch and followed the instructions but ran 
into these problems which the patch should have solved, I thought.

I did NOT mount /bin as per Morlocks instructions and could not access
to obtain a description of the how and why of this.

I am not building on C:
I am buiding on E: with E: mounted as / (default on my system)
A directory /usr/local exists
A directory /usr/local/bin is in my execution path
I am running as Adminstrateur

I read the instructions and prepared the source.
After patching I did the following.

I modified gcc2 and ld2 so that they both contain ':' as the first character.  
If I do not do this, they do not execute.

I modified to add a line.  This is for install.

I added a symbolic link to /usr.  This corresponds to the path used in patch.
ln -s /cygnus/cygwin-b20/H-i586-cygwin32/i586-cygwin32

I then copied the indicated files, ran sh Configure -d and ran make with the 
above problems.  I tried "mount -b e: /" and redid the entire procedure but 
this did not even allow Configure to create files properly.  I tried patching ( so that the symbolic link would not be neccessary but 
this did not change anything.  I tried not adding the prefix line, but the 
file permissions were still incorrect for installing.  I tried building using 
dynamic rather than static libraries and saw no difference in the end result.

Want to unsubscribe from this list?
Send a message to

More information about the Cygwin mailing list