Make 3.77 $(shell) function problems

Michael K. Elwood
Mon May 31 21:10:00 GMT 1999

>I'm having a bit of trouble with cygwin Make 3.77. The $(shell ...)
>does not seem to be working properly. It's not returning the output of the
>shell command. Here is a simple test makefile:
>shelltest = $(shell echo Hello)
>    @echo Shelltest = $(shelltest)

>When I run this using cygwin Make 3.77, I get:
>Shelltest =
>I tried this on one of our linux boxes using Make 3.76.1, and I get:
>Shelltest = Hello

Apologies for replying to my own post, but I have some additional
information. This problem only seems to occur in the mingw32 make (version
3.77 from JanJaap's site). The cygwin make (my current installation has make
3.75) does not show this behavior.

Putting single quotes around the shell command (i.e. $(shell 'echo Hello'),
as someone suggested) did not help, but it did cause make to emit the
following error message:

process_begin: CreateProcess((null), "echo Hello", ...) failed.
make: *** expand_function: unable to launch process (e=2)
.  Stop.

Best regards,


Want to unsubscribe from this list?
Send a message to

More information about the Cygwin mailing list