GDB

Suhaib M. Siddiqi ssiddiqi@ipass.net
Mon May 31 21:10:00 GMT 1999


> > > I get a segmentation failt in gdb before it trips a break on main.
> > > 
> > > I've got a couple of strange dll's (ones associated with stuff
> > > I'd thought I'd de-installed) in reported gdb startup. I suppose an
> > > NT reinstall will be required to get rid of them.
> > > 
> > 
> > Perhaps you have problems with your DLLs or installation.  GDB newest release from
> > Mumit khan works perfect.
> 
> There IS a serious problem with gdb and DLLs. I've been working with
> Mumit for a long time now trying to track this one down. Apparently,
> if you have more than 6 or 7 DLLs to load during startup, you get
> the seg fault. I'm not sure if this is true on NT or not - I haven't
> been able to build a program that needs that many DLLs on NT.
> >From the output of gdb, I suspect there is a problem trying to
> load symbol tables from the DLL. 
> 

Not sure it the the "more then 6 or 7 DLLs" loading is a universal problem with gdb.

I hav an application which uses 9 DLLs and I was able to debug it with out problems.

Regards

Suhaib



> > 
> > Suhaib
> > 
> > > Any suggestions?  -- Stan
> > > 
> > > 
> > > --
> > > Want to unsubscribe from this list?
> > > Send a message to cygwin-unsubscribe@sourceware.cygnus.com
> > > 
> > > 
> > 
> > 
> > --
> > Want to unsubscribe from this list?
> > Send a message to cygwin-unsubscribe@sourceware.cygnus.com
> > 
> 
> 
> --
> Want to unsubscribe from this list?
> Send a message to cygwin-unsubscribe@sourceware.cygnus.com
> 
> 


--
Want to unsubscribe from this list?
Send a message to cygwin-unsubscribe@sourceware.cygnus.com



More information about the Cygwin mailing list