CygWin B20.1 problem using async serial device

Georges Bachelier
Sun Jan 30 12:15:00 GMT 2000


I run the attached async.c program which continuously sends the
'U' character to the /dev/com1 serial device and should stop when it
receives a SIGIO signal. My PC1 platform (on which I run CygWin under
Windows 89 version 2) is connected to another one (let's call it PC2)
running the Terminal application; therefore, I can see the "UUUUUU..."
stream in the PC2 Terminal window but, when I press a key on PC2,
nothing happens.

I have found the async.c code in the LINUX Serial Programming Howto and
the program does work fine under LINUX environment.

I have already read the FAQs and the mailing list archives; there is a
similar to mine, but... no answer.

You can compile async.c with: gcc async.c -DWINDOWS -o async

Could you please answer quickly if what I intend to do is feasible or
not using
CygWin? I am currently in the feasability study phase of a project which

keyword is PORTABILITY. Maybe must I modify the C code to suit to some
CygWin constraint; this is not a problem. What we want to avoid is
having to
write the whole serial link stuff for WINDOWS API!!!

Could you please answer me to the following address:

Best regards,


-------------- next part --------------
A non-text attachment was scrubbed...
Name: Async.c
Type: text/x-c
Size: 2934 bytes
Desc: not available
URL: <>

More information about the Cygwin mailing list