[BUG] Inetd listening on ports it's not configured for

Ronald Landheer ronald.landheer@minisat.com
Thu Dec 6 03:16:00 GMT 2001


Hello all,

I have installed and configured the latest version of Cywin with all
packages, updated whenever there's an announcement, etc.

A while ago, I configured inetd to run telnet whenever necessary, but
*not* FTP. I have a propriatary FTP server running on the same NT/2000
machine, which takes care of the FTP.

Yesterday, I updated both, and the FTP no longer worked. My liking
Cygwin very much, I blamed the FTP server, uninstalled, reinstalled,
didn't work (though with propriatary programs, it usually does ;)
I reconfigured it to listen on port 1024 in stead of 21, and telnetted
to the machine on said port - worked like a charm.
I blamed Windows, did some nmapping, and found something was still
listening on port 21.
There's only one other internet-related TCP/IP port-listening
thingemajig on this server: inetd. I telnetted to the machine, shut down
inetd, logged out, could not log in again, FTPd to the machine (after
having reconfigured the FTP server to listen on port 21) and it worked
like a charm.
Me, happy that my backoffices are working again, but also sad, that
Cygwin was the cause.

I have inserted my inetd.conf file before. I should note that this
worked like a charm before I updated my installation yesterday - AFAIK,
it should not be listening on port 21.
Instructions followed to install inetd are those of the proper readme,
ofcourse, so I consider this a bug.

If any more info is wanted, it will be provided :)

Ronald.

-- BEGIN /etc/inetd.conf --
# See "man 8 inetd" for more information.
#
# If you make changes to this file, either reboot your machine or restart
# inetd:
#   "net stop inetd"
#   "net start inetd"
# The inetd will then re-read this file.
#
# <service_name> <sock_type> <proto> <flags> <user> <server_path> <args>
#
echo    stream  tcp     nowait  root    internal
echo    dgram   udp     wait    root    internal
discard stream  tcp     nowait  root    internal
discard dgram   udp     wait    root    internal
daytime stream  tcp     nowait  root    internal
daytime dgram   udp     wait    root    internal
chargen stream  tcp     nowait  root    internal
chargen dgram   udp     wait    root    internal
time    stream  tcp     nowait  root    internal
time    dgram   udp     wait    root    internal
#
# The external services are typically called via 'tcpd' for
# security reasons, eg.
ftp   stream  tcp     nowait  root    /usr/sbin/tcpd in.ftpd
#
# but tcpd is not part of the inetutils, unfortunately.
# Nevertheless there's a port contributed by Prentis Brooks
<prentis@aol.net>
#
# We are calling the services here directly.
#
# These are standard services.
#
#ftp     stream  tcp     nowait  root    /usr/sbin/in.ftpd in.ftpd
telnet  stream  tcp     nowait  root    /usr/sbin/in.telnetd in.telnetd
#
# Shell, login, exec and talk are BSD protocols.
#
shell   stream  tcp     nowait  root    /usr/sbin/in.rshd in.rshd -L
login   stream  tcp     nowait  root    /usr/sbin/in.rlogind in.rlogind
exec    stream  tcp     nowait  root    /usr/sbin/in.rexecd in.rexecd
talk    dgram   udp     wait    root    /usr/sbin/in.talkd in.talkd
ntalk   dgram   udp     wait    root    /usr/sbin/in.talkd in.talkd
#
# The Internet UUCP service.
#
uucp    stream  tcp     nowait  uucp    /usr/sbin/in.uucpd in.uucpd
#
# Tftp service is provided primarily for booting.  Most sites
# run this only on machines acting as "boot servers."
#
# tftp  dgram   udp     wait    nobody  /usr/sbin/in.tftpd in.tftpd

--- END /etc/inetd.conf ---


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Bug reporting:         http://cygwin.com/bugs.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list