[Fwd: Re: Problem using pthreads with GCC under CygWin]

Pavel Tsekov ptsekov@syntrex.com
Tue Dec 11 00:32:00 GMT 2001

Hello, Kay

I dont know too much about this topic - however
someone on the list might help. I've forwarded your
mail there.

-------- Original Message --------
Return-Path: <passhark@hotmail.com>
Delivered-To: ptsekov@mail.syntrex.com
Received: (qmail 17620 invoked by alias); 11 Dec 2001 03:17:04 -0000
Delivered-To: alias-localdelivery-ptsekov@syntrex.com
Received: (qmail 17617 invoked by uid 8); 11 Dec 2001 03:17:04 -0000
Received: from f36.law3.hotmail.com (, claiming to be
"hotmail.com")by mail.syntrex.com with SMTP id smtpd93PPWC; Mon, 10 Dec
2001 22:16:55 EST
Received: from mail pickup service by hotmail.com with Microsoft
SMTPSVC;Mon, 10 Dec 2001 19:15:20 -0800
Received: from by lw3fd.law3.hotmail.msn.com with HTTP;Tue,
11 Dec 2001 03:15:19 GMT
X-Originating-IP: []
From: "Kay M" <passhark@hotmail.com>
To: ptsekov@syntrex.com
Subject: Re: Problem using pthreads with GCC under CygWin
Date: Tue, 11 Dec 2001 03:15:19 +0000
Mime-Version: 1.0
Content-Type: text/plain; format=flowed
Message-ID: <F36VSRvQjLk469K5iFf0000856d@hotmail.com>
X-OriginalArrivalTime: 11 Dec 2001 03:15:20.0082 (UTC)
X-Mozilla-Status: 8011
X-Mozilla-Status2: 00000000
X-UIDL: 1008040624.17622.mail


OK. threads so far is OK with latest CYGWIN. I got it to work..thre is
a .h file.

Ok another prob if ya can help......
Sockets question.
I tried binding a socket to the broadcast address on a client process.
it gives error with EADDRNOAVAIL. I tried specifying 
explicity. On Linux (no real internet) it works OK with same source

>From: Pavel Tsekov <ptsekov@syntrex.com>
>To: Kay M <passhark@hotmail.com>
>CC: cygwin@cygwin.com
>Subject: Re: Problem using pthreads with GCC under CygWin
>Date: Mon, 10 Dec 2001 14:26:48 +0100
>You dont need to add neither -pthread nor -pthreads to
>the gcc command line. pthreads is part of the cygwin
>Kay M wrote:
> >
> > I have win98
> > Have installed Cygwin B20.1 and also have installed version 1.3.3.
> >
> > I have a simple .c file that is a pthreads example.
> >
> > Problem is When I compile it it dont compile. GCC cant see the pthreads
> > libraries. Ive tried the -pthread and -pthreads switch. Ans also 
> > the pthreads.h.
> >
> > There is no pthread.h file in the include directories ?
> >
> > WHat the problem ?.

Get your FREE download of MSN Explorer at

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Bug reporting:         http://cygwin.com/bugs.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list