Problem w/ wildcards w/ tcsh

Jeff Hu
Fri Dec 28 15:07:00 GMT 2001

Try commenting out the "set noglob" line in /etc/csh.cshrc

-----Original Message-----
From: []On Behalf Of
Bill Priest
Sent: Friday, December 28, 2001 4:12 PM
Subject: Problem w/ wildcards w/ tcsh


In win2k service pack 2
CYGWIN set to binmode;tty;ntsec
TERM set to cygwin

        I updated to the latest cygwin using setup and
I noticed that "ls *" doesn't work as expected.
It gives "ls: *:  No such file or directory"

If I do
echo *

Using bash it works as expected; if I do ls "*" in bash I get the same error
as tcsh, so it appears that the shell is not expanding "*" for some reason.

I've been using tcsh for months on this machine and I just got this error

I reverted back to tcsh xx.xx-2 using setup and I get the same results.
I renamed my .tcshrc file and I get the same results.
My mounts are all binary

I just tried the following on a different machine.
Updated all cygwin except tcsh
executed cygwin.bat and "ls *" worked as expected
Updated tcsh to -2 (ie. previous in setup) and "ls *" stopped working (ie.
as above)
Updated tcsh to -3 (ie. current in setup) and "ls *" remained not working

Is anyone else seeing this problem?
Since I don't know how to go back to the "-1" version and source, I'm not
sure how
to isolate this problem further.

Any hints or pointers to the source versions (specifically the -1 that
works); I know
how to get the source for -2.


PS.  If there is further information required to debug this problem; please
email me
directly as I am on digest for cygwin.

Do You Yahoo!?
Get your free address at

Unsubscribe info:
Bug reporting:

Unsubscribe info:
Bug reporting:

More information about the Cygwin mailing list