Can't run Macro Express from within Cygwin bash shell

Michael A Chase mchase@ix.netcom.com
Wed Dec 4 18:46:00 GMT 2002


On Wed, 04 Dec 2002 18:12:20 -0800 Jack Twilley <jtwilley@brightmail.com> wrote:

> This is probably a general question and not application-specific.
> 
> I can run the application from a cmd window in Win2kAS with a command
> line like this:
> 
> c:\progra~1\macroe~1\meproc.exe /Fj:\diesel\scripts\PerfmonMacros.mex
> /APerfMonInit
> 
> I've tried running the same command line with lots of escaping from a
> Cygwin bash shell, both remotely and locally.  It doesn't work.  I've
> tried mixtures of /cygdrive/c and c:\\ and I can see the files in the
> remote directory from the bash shells just fine.  What am I doing
> wrong?

If it's a MSDOS/Windows executable, it won't know anything about Cygwin
paths.  Getting backslashes (\) right can be rather tricky in a shell
environment, so what I'd suggest is something like this:

 # A DOS program won't understand Cygwin file specifications
 mex=$(cygpath -w -a /cygdrive/j/diesel/scripts/PerfmonMacros.mex)

 # Use a Cygwin path for the shell to find the program
 "/cygdrive/c/Program Files/MacroExe/meproc" /F$mex /APerfMonInit

-- 
Mac :})
** I normally forward private questions to the appropriate mail list. **
Ask Smarter: http://www.tuxedo.org/~esr/faqs/smart-questions.html
Give a hobbit a fish and he eats fish for a day.
Give a hobbit a ring and he eats fish for an age.



--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Bug reporting:         http://cygwin.com/bugs.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list