/etc/inetd.conf: No such file or directory

Mikhail Teterin mi@corbulon.video-collage.com
Wed Dec 18 19:59:00 GMT 2002


> Yes, it does.  The trouble is that these are *user* mounts.  This means
> that another user will not see these mounts.

You are right! But why did it happen? I just did a complete reinstall of
Cygwin... Is it because it was previously installed by a non-admin user
and some registry setting were left, which prevented the new install from
setting them? Thank you. Yours,

	-mi
 
> > Why is the inetd.conf not found,
> > even though both -- the cmd's ``dir'' and CygWin's ls confirm its presense:
> >
> >         C:\>dir C:\cygwin\etc\inetd.conf
> >          Volume in drive C has no label.
> >          Volume Serial Number is 07D1-0517
> >
> >          Directory of C:\cygwin\etc
> >
> >         12/16/2002  02:01p               1,973 inetd.conf
> >                        1 File(s)          1,973 bytes
> >                        0 Dir(s)  23,927,029,760 bytes free
> >         mteterin@doofus:~ (439) ls -l /etc/inetd.conf
> >         -rw-r--r--    1 mteterin unknown      1973 Dec 16 14:01 /etc/inetd.conf
> >
> > ? Thank you,
> >         -mi
> 
> The user "mteterin" does see the file in /etc, since for the user
> "mteterin" the mount table points "/" to "c:\cygwin".  However, the inetd
> daemon (and other services, actually) run as the "SYSTEM" user, which will
> not see *user* mounts, so doesn't know where to find "/".
> 
> The solution is to remount all your directories as system mounts, by
> running something like:
> 
> $ eval `mount -m | sed -e 's/-u/-s/' -e 's/$/;/g'`
> 
> This should fix your problem.  Try starting the service again.
> 
> If this doesn't work, you may have somehow acquired user mounts for the
> user SYSTEM.  The following works on Win2k, but I haven't verified it on
> any other system:
> To check for user mounts, get a SYSTEM shell (by typing
> 
> $ at `date -d 'next min' +%T` /interactive 'c:\cygwin\bin\bash.exe'
> 
> in bash and waiting at most 1 minute), and run "mount" from there to make
> sure you only have system mounts.  If you see user mounts from that shell,
> run "umount -u 'mount_point'" for each user mount_point.
> 	Igor

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Bug reporting:         http://cygwin.com/bugs.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list