problems creating apache service

lhall@pop.ma.ultranet.com lhall@pop.ma.ultranet.com
Thu Dec 19 13:41:00 GMT 2002


Sorry, I don't have apache installed here but I think what you're 
seeing is a general "mismapping" between the parameters cygrunsrv takes
and what's reported in the services applet.  You'll see the same thing
with sshd or any other service you install with cygrunsrv.  It's nothing
to worry about and not the source of your problems.  You should review 
the information in the Apache readme for Cygwin and the Cygwin archives 
to help you track your problem further.

Larry

Original Message:
-----------------
From: Paul Cantalupo lupey+@pitt.edu
Date: Thu, 19 Dec 2002 15:23:04 -0500
To: cygwin@cygwin.com
Subject: problems creating apache service


Hello,

I am using cygwin 1.3.17 on Windows 2000 (SP3) and cygwin apache 1.3.24.
I read the Apache/Cygwin page, http://httpd.apache.org/docs/cygwin.html,
to figure how to run apache as a service. I used this command line:

cygrunsrv -I apache -p /usr/sbin/httpd.exe

The service is created just fine but then, under the apache service
properties, the "Path to Executable" contains
"C:\cygwin\bin\cygrunsrv.exe". So naturally, when I click "Start",
Apache doesn't start and I get an error message saying that the apache
service couldn't be started.

What gives here? The Path to Executable should be /usr/sbin/httpd.exe,
right?

Thanks,

Paul


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Bug reporting:         http://cygwin.com/bugs.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/


--------------------------------------------------------------------
mail2web - Check your email from the web at
http://mail2web.com/ .



--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Bug reporting:         http://cygwin.com/bugs.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list