Sshd: Resource temporarily unavailable

Campbell Fethers
Fri Dec 20 16:54:00 GMT 2002

An embedded and charset-unspecified text was scrubbed...
URL: <>
-------------- next part --------------
W2kpro, sp2
Appears to close the socket immediately after connection.
ssh -v reports "Read from socket failed: Connection aborted"

A log of sshd (thanks to Max's instructions) shows
"Read from socket failed: Resource temporarily unavailable"

Tried deleting cygwin installation and reinstalling. Results attached.

Also tried backdating OpenSSL lib. Still didn't work :-( which suggests that
something else has changed on my system. Likely.

A search of for "Resource temporarily unavailable" yields:
Resource temporarily unavailable.
This error is returned from operations on nonblocking sockets that cannot be
completed immediately, for example recv when no data is queued to be read
from the socket. It is a nonfatal error, and the operation should be retried
later. It is normal for WSAEWOULDBLOCK to be reported as the result from
calling connect on a nonblocking SOCK_STREAM socket, since some time must
elapse for the connection to be established.

The only solution found so far is to completely reinstall W2k,

Spurious WSAEWOULDBLOCKs seem to have caused problems when closing sockets, and
also problems with postgres.

My theory, for what it is worth, is that windows is sending an event saying
that there is something ready to read from a socket, but returns
WSAEWOULDBLOCK when the program reads the socket. I think I read somewhere
in a Microsoft page that programs have to be able to cope with this
situation. It is likely a timing related.



-------------- next part --------------
Unsubscribe info:
Bug reporting:

More information about the Cygwin mailing list