Delays With Pipes In Cygwin 1.3.18

Randall R Schulz
Thu Dec 26 18:48:00 GMT 2002


I just upgraded to Cygwin 1.3.18:

% uname -a
CYGWIN_NT-5.0 CLEMENS 1.3.18(0.69/3/2) 2002-12-25 15:37 i686 unknown

Immediately after doing so I began noticing a heretofore unseen problem.

Every command I run that involves a pipe produces a large delay, though 
they all eventually complete normally. This is true when I use the pipeline 
explicitly or in a shell procedure or alias as well as in commands such as 
"man" that use pipes internally.

Using "nice" to start a shell with elevated priority (including going all 
the way to "nice --20" which produces a process listed as "High" priority 
in the Task Manager) does not alter this symptom. As expected, the elevated 
scheduling priority is inherited by the shell's children, but the delay 

I run the SETI@home client in always-on mode and that program is shown as 
having the lowest priority in the Windows Task Manager (by right-clicking 
on the "SETI@home.exe" line in the "Process" tab and opening the "Set 
Priority" sub-menu). BASH has "Normal" priority.

On a hunch, I stopped the SETI@home process and then pipelines complete 
with their usual alacrity even when started at the normal priority.

Nothing like this ever happened in the past, so I imagine this symptom is 
somehow related to the Cygwin changes that were designed to give better 
pipe performance.

I've attached "cygcheck -s -v" output.

I'd be happy to run other tests or supply other diagnostic information if 
anyone would like me to.

Randall Schulz
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck-slowpipe-out
Type: application/octet-stream
Size: 27531 bytes
Desc: not available
URL: <>
-------------- next part --------------
Unsubscribe info:
Bug reporting:

More information about the Cygwin mailing list