Win32 Error 1062: The Service has not been started

Igor Pechtchanski pechtcha@cs.nyu.edu
Fri Dec 17 17:24:00 GMT 2004


On Fri, 17 Dec 2004, Mark Flattery wrote:

> My installation of cygwin (1.3.12) on to a Windows NT4.0 machine has

Ugh.  If none of the standard steps below work, please try upgrading.
You're wa-ay behind on most packages, most importantly openssh.

> failed at the final hurdle trying to start the service: -
>
> 	D:\cygwin\cygwin\bin>cygrunsrv -I sshd -p /usr/sbin/sshd -e PATH="/bin:$PATH"
>
> 	D:\cygwin\cygwin\bin>cygrunsrv -S sshd
> 	cygrunsrv: Error starting a service: QueryServiceStatus:  Win32 error 1062:
> 	The service has not been started.

The real error is usually in the logs (either the Event Log, or in
/var/log/sshd.log).  It's usually a permissions problem.

> I know this has been raised before and believe me I have searched the
> archives and found people have managed to solve this in different ways.
> I've re-mounted all of my mounts as "system" :
>     mount -m | sed -e 's/ -u / -s /g' -e 's/$/;/'

Hate to break it to you, but no, you didn't.  You forgot to eval the
result of the above, so all you did was print the right mount commands to
the screen.  You should have used (eval "`mount -m | sed -e 's/ -u / -s
/g' -e 's/$/;/'`") instead.

Luckily for you, you already had the system mounts (according to your
cygcheck output).

> I've checked and changed permissions to the entire cygwin directory and
> cannot get the service to start.

Changed permissions to what?  Do all the DLLs used by sshd have execute
permission on them (as required by Windows)?

> My suspicion is something on the server rather than the cygwin
> installation package as this same package has been used on over 400
> windows servers without this problem happening before. (maybe a security
> policy has been implemented on the server farm that I don't know about)

Did you try to start a system-owned shell and run sshd from there?

> The installation appears to work on some servers and fails on a few. I've
> checked a working servers cygcheck output from a failed one and can't see
> anything obvious.

Thanks, but in the future, please *attach* the output of cygcheck, to
avoid introducing false positives into archive searches.

> Any help someone can give to point me in the right direction
> would be great, I've been looking at this for days.

Hope the above helps,
	Igor
-- 
				http://cs.nyu.edu/~pechtcha/
      |\      _,,,---,,_		pechtcha@cs.nyu.edu
ZZZzz /,`.-'`'    -.  ;-;;,_		igor@watson.ibm.com
     |,4-  ) )-,_. ,\ (  `'-'		Igor Pechtchanski, Ph.D.
    '---''(_/--'  `-'\_) fL	a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!

"The Sun will pass between the Earth and the Moon tonight for a total
Lunar eclipse..." -- WCBS Radio Newsbrief, Oct 27 2004, 12:01 pm EDT

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list