Call for testing Cygwin snapshot (problem with getline?)

Corinna Vinschen
Mon Dec 5 10:19:00 GMT 2005

On Dec  5 11:06, Nenad Antic wrote:
> Corinna Vinschen wrote, on 11/30/2005 6:11 PM:
> >1.5.19 has also some new functionality over 1.5.18.  If you have sources
> >which take advantage of that stuff if present, we're also interested in
> >getting feeedback about those:
> > 
> >
> ...
> > - getline, getdelim.
> > 
> >
> ...
> I mentioned this when struggling with my mod_perl issues a few weeks 
> back.  Building apache worked without any hassles before (whenever I 
> tried) and also as late as 1.5.18. However now (tried snapshot 20051201 
> last) this happens:
> ...
> gcc -c  -I../os/cygwin -I../include   -DCYGWIN -DNO_DBM_REWRITEMAP 
> -DUSE_HSREGEX  -DSHARED_CORE `../apaci` htpasswd.c
> htpasswd.c:101: error: conflicting types for 'getline'
> /usr/include/sys/stdio.h:31: error: previous declaration of 'getline' 
> was here

That's a problem with the package.  Two possible causes:

- Either the mod_perl packages has no configure check for getline and
  just tries to use its own version in htpasswd.c on some platforms,
  in this case such a test should be added,

- or you tried to rebuild the package without configuring again.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat, Inc.

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list