Call for testing Cygwin snapshot (problem with getline?)

Nenad Antic nenad.antic@ericsson.com
Mon Dec 5 11:05:00 GMT 2005


Corinna Vinschen wrote, on 12/5/2005 11:21 AM:

>On Dec  5 11:19, Corinna Vinschen wrote:
>  
>
>>On Dec  5 11:06, Nenad Antic wrote:
>>    
>>
>>>gcc -c  -I../os/cygwin -I../include   -DCYGWIN -DNO_DBM_REWRITEMAP 
>>>-DUSE_HSREGEX  -DSHARED_CORE `../apaci` htpasswd.c
>>>htpasswd.c:101: error: conflicting types for 'getline'
>>>/usr/include/sys/stdio.h:31: error: previous declaration of 'getline' 
>>>was here
>>>      
>>>
>>That's a problem with the package.  Two possible causes:
>>
>>- Either the mod_perl packages has no configure check for getline and
>>  just tries to use its own version in htpasswd.c on some platforms,
>>  in this case such a test should be added,
>>
>>- or you tried to rebuild the package without configuring again.
>>    
>>
>
>I forgot this: Note that getline is new in 1.5.19.  The definition
>of the function is compatible with the glibc definition,
>
>  ssize_t getline (char **, size_t *, FILE *);
>
>
>Corinna
>
>  
>
Actually, I didn't mean that this happens only when building vith 
mod_perl (event though that's how if ran into it). It happens when 
configuring apache (1.33 and 1.34, at least), even with the fixes that 
exist in the cygwin packages. AFAIK apache builds fine on linux (did it 
on a debian installation roughly a year ago, don't have access to any 
linux box at the moment so I can't test it side to side) and linux 
distros normally have glibc included, don't they(?).

/nenad



--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list