rysnc hangs when backing up multiple /cygdrive/* dirs

H.S. hs.samix@gmail.com
Mon Dec 5 19:50:00 GMT 2005


H.S. wrote:
> H.S. wrote:
> 
>>Hi,
>>
>>I am not able to see what could be going wrong with my rsync method. I
>>am trying to back up a Windows XP box (running Cygwin and sshd and
>>rsyncd)  from my Debian Testing box. The following command hangs before
>>really transfering any files:
>>
>>rsync -R --delete --delete-excluded --modify-window=1 --ignore-errors
>>-zauve ssh --exclude-from=rsync-excludes.txt
>>'ice:/cygdrive/c/Documents?and?Settings  /cygdrive/d/user1 /home   /etc'
>>/mnt/snapshot/ice/windows/daily.0
>>
>>
>>but the following command works:
>>
>>rsync -R --delete --delete-excluded --modify-window=1 --ignore-errors
>>-zauve ssh --exclude-from=rsync-excludes.txt
>>'ice:/cygdrive/c/Documents?and?Settings /home   /etc'
>>/mnt/snapshot/ice/windows/daily.0
>>
>>
>>I notice that if I specify multiple source /cygdrive/* dirs to be backed
>>up, rsync hangs (first case above), otherwise it is happy (second case
>>above).
>>
>>Can anybody see what could be the problem? Or, how do you backup
>>multiple dirs from a cygwin box?
>>
>>->HS
>>
>>
> 
> 
> 
> Well, it appears something is wrong with my rsync'ing /cygdrive/d. I am
> not able to rsync and backup /cygdrive/d/user1 directory at all! The
> rsync process just hangs. Rsync works on other directories in
> /cygdrive/c and / but not on /cygdrive/d/<dirs>.
> 
> Here is what I have on the Windows XP box running Cygwin:
> $ mount
> C:\cygwin\bin on /usr/bin type system (binmode)
> C:\cygwin\lib on /usr/lib type system (binmode)
> C:\cygwin on / type system (binmode)
> c: on /cygdrive/c type system (binmode,noumount)
> d: on /cygdrive/d type system (binmode,noumount)
> e: on /cygdrive/e type system (binmode,noumount)
> 
> 
> Any comments?
> ->HS
> 
> 
> 
> 

I don't know why, but it is working now. I exluded the .lnk files and
backup the d drive folder separately first. Then I included other
directories to backed up. Now I am backing up only '/cygdrive/d/sukh
/cygdrive/c/Documents\ and\ Settings' and it seems tobe working great.
Well, not 100% great, I am posting that problem in a different post shortly.

->HS



--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list