Hang with 20051205 snapshot while building OOo

Yitzchak Scott-Thoennes sthoenna@efn.org
Fri Dec 9 03:24:00 GMT 2005


On Thu, Dec 08, 2005 at 03:23:01PM -0800, Yitzchak Scott-Thoennes wrote:
> On Wed, Dec 07, 2005 at 01:15:50PM -0500, Christopher Faylor wrote:
> > On Wed, Dec 07, 2005 at 05:16:17PM +0100, Volker Quetschke wrote:
> > >We got some new features in the hangs with the 20051205 snapshot
> > >when building OOo.
> > >
> > >This trace looks a little bit different from the old versions,
> > >see thread around <http://sourceware.org/ml/cygwin/2005-10/msg00600.html>,
> > >but it still hangs.
> > 
> > It looks different because I took out all of the debugging strace
> > output that I added to try to track this down.
> > 
> > I'm convinced that the hang is coming from timeGetTime.  That's a
> > Windows routine and there's not much I can do if a windows routine
> > decides to take a long time to return.
> > 
> > So, in other words, I'm admitting defeat in this case, especially since
> > this isn't a regression from 1.5.18.
> 
> This is likely to enable a fix or workaround in cygwin, but is it

          ^un !

> possible that this is restricted to certain brands, models, or
> revisions of processor?  Am I correct in remembering that it happens
> only on some machines, Volker?
> 
> --
> Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
> Problem reports:       http://cygwin.com/problems.html
> Documentation:         http://cygwin.com/docs.html
> FAQ:                   http://cygwin.com/faq/
> 

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list