expect script hanging: ssh to localhost w/password authentication

Christopher Faylor cgf-no-personal-reply-please@cygwin.com
Wed Dec 21 04:00:00 GMT 2005

On Tue, Dec 20, 2005 at 07:02:12PM -0600, cygwin@trodman.com wrote:
>On Tue 12/20/05 22:01 +0100 cygwin@cygwin.com wrote:
>> On Dec 19 11:00, Tom Rodman wrote:
>> > Enclosed is an expect script (to ssh to the localhost with password
>> > authentication) that "hangs" (search ahead for "parent: waiting for sync byte")
>> > with the Dec 16 snapshot. Please take a look at the working and
>> > non-working test cases below.
>> Looks like we found the cause for this effect.  Please try
>> the next developers snapshot (2005-Dec-20 and later) from
>> http://cygwin.com/snapshots/
>Thank-you!  I tried the Dec 20 snapshot dated (~15:36 if I recall right),
>and the expect script worked fine; as a bonus it looks it yielded all
>the output wanted.  Sorry I'm being so general..any how thanks again.
>There seems to be a new (related?) issue w/this Dec 20 snapshot.  I don't
>have time to log the test formally now; I hope you will see the problem if
>you run:
>  ssh localhost date
>At least in the case were you are prompted for your password, the
>date command either does not run or it's output is lost.



Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list