setup/symlinks/gcc/chown question

Karl M
Wed Dec 21 04:28:00 GMT 2005

Hi All...

Attached is the output of

strace -o outfile chown -h administrators.none collect2.exe

executed in


after having reinstalled gcc/mingw tools.

I am using Cygwin chown. (I did mention it in my last email, but it is easy 
to miss.)



>From: Corinna Vinschen Subject: Re: setup/symlinks/gcc/chown question
>Date: Tue, 20 Dec 2005 17:15:59 +0100
>On Dec 19 09:37, Karl M wrote:
> > Hi All...
> >
> > I see the broken links on any machine I use. I run as a restricted user,
> > except when I am installing or updating software. Here is the way I do 
> > initial install (to prevent permissions leaks)...
>Well, I still can't reproduce it and I didn't get any hint that somebody
>else can reproduce this.  I tried chmod -R and chown -R on directories
>containing symlinks created by a former setup.exe call and the symlinks
>were still symlinks afterwards.
>Let's restart with my previous mail:
> > >Are you sure you're using Cygwin's chmod/chown?  Did you try to run 
> > >under strace and see what happens?
>Corinna Vinschen                  Please, send mails regarding Cygwin to
>Cygwin Project Co-Leader          cygwin AT cygwin DOT com
>Red Hat
>Unsubscribe info:
>Problem reports:

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: outfile
URL: <>
-------------- next part --------------
Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list