SSH problem after upgrade

Ed Brady
Wed Dec 21 05:32:00 GMT 2005

Larry Hall (Cygwin) wrote:

> Ed Brady wrote:
>> After upgrading to the latest release of cygwin, I am continually 
>> receiving the error message.
>> socket:  Operation not permitted
>> ssh:  connect to host port 22: Operation not permitted
>> I have had Cygwin installed on this computer for over three years and 
>> have used ssh reguarly without any problems until this recent upgrade.
>> Also, I can copy ssh.exe to my home directory and for some strange 
>> reason this seems to work.  I have searched all over for an answer to 
>> this problem with no avail.
>> Any help appreciated
> Have you tried enabling the debug options on the client and server and
> analyzing the results?  Have you tried the latest cygwin snapshot to see
> if that helps?  If these don't help point the way, please read and follow
> the problem reporting guidelines at <>.
> From your description so far, this sounds like a local problem so having
> more info about what you're doing and what your installation is will be
> crucial to diagnosing the actual cause of the problem.

Thanks for the reply,

As of this morning (12/20) here are the steps I have taken...

#1 Completely removed existing Cygwin installation
#2 Reinstalled with latest released version per setup.exe.    Installed 
ALL available Cygwin packages.
#3 Witnessed the same behavior  as reported  in the previous post.  
Additional  notes follow..

What I am trying to  do is establish an outbound connection using the 
ssh client located in /usr/bin to a number of identified servers.   
Attempts to connect to all three servers fail with the error messages:
socket:  Operation not permitted
ssh: connect to host port 22:  Operation not permitted.

I have enabled debug options on the client, but it hasn't given any good 
clues....  It dies fairly quickly, below is the pasting of the debug 

OpenSSH_4.2p1, OpenSSL 0.9.8a 11 Oct 2005
debug2: ssh_connect: needpriv 0
debug1: Connecting to gatekeeper [] port 22.
socket: Operation not permitted
ssh: connect to host gatekeeper port 22: Operation not permitted

However, if I copy ssh.exe to my home directory, it works as intended 
without any problems....

I have noticed that this problem also exists with telnet.exe and 
ftp.exe.  Specifically, if I try to invoke either of these apps directly 
from /usr/bin it will give a similar error message.
"socket:  Operation not permitted"
however if I copy them to my home directory (/home/Ed), they will also 
work as intended

The latest snapshot did not yield any results, (however this is the 
first time I have tried one so there is some room for error on my part 
in the area of installation and usage...)

cygcheck information is attached

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: cygcheck.txt
URL: <>
-------------- next part --------------
Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list