strange hang/loop with 20051224 - 14:34 snapshot

Volker Quetschke quetschke@scytek.de
Sun Dec 25 18:16:00 GMT 2005


Volker Quetschke wrote:
> With the 20051224 - 14:34 snapshot I see a strange hang while
> building OOo.
> 
> The build script hangs and the system is running on 100%. Now the
> funny part. I see one perl "hanging" (process is shown by ps and
> task manager) and I see another perl process (only shown in the task
> manager)
This is not true. These processes are also shown by ps, but they change
so rapidly that they didn't match the PIDs from the task manager.


> popping up with a lot of resource use (30-70%) and then
> vanishing again. Whenever the task manager refreshes the processes
> there is this second perl, but always with a new PID.
> 
> A "ls /proc/*/fd" doesn't help either, but it shows some lines like this:
> 
> ...
> ls: /proc/2468/fd: No such file or directory
> 
> /proc/2604/fd:
> 0@  1@  2@  3@  4@
> 
> /proc/3380/fd:
> 0@  1@  2@  3@
> ls: cannot read symbolic link /proc/3424/fd/3: No such file or directory
> ...
> 
> I don't have a short testcase :( .
> 
> Unfortunately I didn't test all the recent snapshots, the previous
> one (it worked for me) was from 20051106.
> 
>   Volker
> 


-- 
PGP/GPG key  (ID: 0x9F8A785D)  available  from  wwwkeys.de.pgp.net
key-fingerprint 550D F17E B082 A3E9 F913  9E53 3D35 C9BA 9F8A 785D
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 254 bytes
Desc: OpenPGP digital signature
URL: <http://cygwin.com/pipermail/cygwin/attachments/20051225/89017582/attachment.sig>


More information about the Cygwin mailing list