nedit 5.4 and 5.5 - locale not supported problem

Gary R. Van Sickle g.r.vansickle@worldnet.att.net
Fri Jun 3 17:18:00 GMT 2005


> -----Original Message-----
> From: cygwin-owner@cygwin.com 
> [mailto:cygwin-owner@cygwin.com] On Behalf Of Ireneusz R. Janiszewski
> Sent: Friday, June 03, 2005 12:09 PM
> To: cygwin@cygwin.com
> Subject: nedit 5.4 and 5.5 - locale not supported problem
> 
> Hello,
> 
> I am trying to use nedit 5.5 or 5.4 with locale "pl" but I 
> have encountered problem, which I cannot solve.
> The nedit reports "locale not supported by C library, locale 
> unchanged" 
> and in fact I cannot enter the locale specific characters. 
> All existing documents are displayed correctly in the nedit. 
> Problem is only with text typing.
> 
> ------------------------------------------------------------------
> $ nedit -V
> locale not supported by C library, locale unchanged NEdit 5.5 
> Sep 30, 2004
> 
>       Built on: Win32, 386, GNU C
>       Built at: Oct 16 2004, 06:48:22
>     With Motif: 2.1.0 [@(#)GNU/LessTif Version 2.1 Release 
> 0.93.94] Running Motif: 2.1 [unknown]
>         Server: The Cygwin/X Project 60802000
>         Visual: 24-bit TrueColor (ID 0x22, Default)
>         Locale: C
> ------------------------------------------------------------------
> 
> I have set variables "LANG=pl_PL" and "LC_ALL=pl_PL". With 
> this configuration I can run and successfully use nedit 5.3. 
> The version is unfortunately the last nedit version I can use 
> without the locale problem.
> 
> The runtime requirements, which I have found in nedit package 
> documentation are met. Currently I am using:
> cygwin-1.5.17-1
> expat-1.95.8-1
> lesstif-0.93.94-2
> libfontconfig1-2.2.2-1
> libfreetype26-2.1.5-1
> libXft2-2.1.6-1
> xorg-x11-bin-dlls-6.8.2.0-1
> zlib-1.2.2-1
> 
> I have to mention, that the nedit is the only one application 
> with the locale problem in my Cygwin installation. Could 
> somebody help me, please?
> 
> Best regards,
> Irek

Unfortunately, Cygwin has never supported C locales, since it uses the
newlib C library (which doesn't support them).  Are 5.3 and 5.4+ linked
differently?  See what "cygcheck nedit.exe" says.  I don't know why you'd
get different results with the older version, since again locales weren't
ever supported.

-- 
Gary R. Van Sickle
 


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list