Problem with using stripped cygwin1.dll built from CVS

Corinna Vinschen
Wed Jun 8 08:57:00 GMT 2005

On Jun  7 16:50, David Rothenberger wrote:
> On 6/7/2005 4:28 PM, Brian Dessent wrote:
> >Part of the new cygheap changes that cgf recently checked in, were a
> >number of changes/tweaks to the linker script.  It's possible that your
> >checkout happened in the middle of those changes, or you didn't get them
> >all.  Try a recent checkout.  (If you are already using an up to date
> >tree, then ignore this...)
> Total up-to-date tree. I did a cvs update -A this afternoon. I also get 
> this same error if I run strip (w/o args) on the DLL from the latest 
> snapshot.

Weird.  I had this when trying to build Cygwin with Dwarf2 debugging
information and the linker script wasn't aware of the additional sections.
Could you paste the output of `objdump -h cygwin1.dll' of a stripped and
an unstripped DLL?


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader
Red Hat, Inc.

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list