Login & Something diff since cygwin 1.5.15-1 release - could it be security changes that were made

Corinna Vinschen corinna-cygwin@cygwin.com
Wed Jun 8 11:22:00 GMT 2005


On Jun  7 16:13, Brian Keener wrote:
> I have attached the log (log14.out).  Just in case I did this for 1.5.17 as
> well just in case it would be helpful (log17.out).

I didn't expect that but actually the log from 1.5.17 was more informative
than the 1.5.14 one.  Thanks for sending it.  Apparently there's something
different in the LogonUser handling of W2K than in any other system.

According to my tests you must have given the "Act as part of the operating
system" privilege (SeTcbPrivilege) to your account.  Only when I added this
to my W2K account I got the same error as you, which was an "access denied"
in the LogonUser call.  This does not happen in XP or 2K3 with 1.5.17.

So I see now what happens, but there's no satisfying explanation other than
"well, it's just the way it is on W2K".  It's enough to create a workaround,
though.  I've checked in a change to the Cygwin DLL which works for me on
W2K, as long as SeTcbPrivilege is given to my account.

Please test the next snapshot from http://cygwin.com/snapshots/


Thanks,
Corinna

-- 
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          mailto:cygwin@cygwin.com
Red Hat, Inc.

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list