passwd & group file problems ?

Igor Pechtchanski
Thu Jun 9 20:52:00 GMT 2005

Yuk, top posting.  Reformatted.  Please consider pressing Ctrl-End in the
Message text area...

On Thu, 9 Jun 2005, Roy Wiseman wrote:

> --- Dave Korn <dave.korn@XXXXXX.XXX> wrote:

...after changing the first line of the reply quote.  As I mentioned,
<>.  I know it's Yahoo webmail,
so doesn't have much in the way of convenience features, but at worst
you'd have to remove the addresses by hand.  Anything to avoid helping
spammers.  If this is sufficiently annoying, perhaps enough Yahoo users
will request this feature that Yahoo will give in and implement it.

> > ----Original Message----
> > >From: Igor Pechtchanski
> > >Sent: 09 June 2005 18:09
> >
> > > likely to bite you at some point soon.  Secondly, some application
> > > (presumably Norton Ghost) has inserted a quoted string into your
> > > PATH, which confuses Cygwin.  Remove the quotes from the PATH.
> >
> >   At this point, I'd just like to say ${DAVEK_ANTI_NORTON_RANT}, and
> > furthermore,
> > while of course it is also true that

At this point, Dave, it might pay for you to actually create a web page
with the rants and post links... :-p

> > > Also, as your cygcheck output shows, you are in a domain.  It's
> > > quite possible that the domain controller really is taking more than
> > > 30 minutes to return the set of users and groups (for large
> > > domains).  The "-u"/"-g" options of mkpasswd/mkgroup respectively
> > > may be helpful.
> >
> >   Or indeed running it in such a way that the redirection doesn't
> > prevent you from seeing what's going on, such as:
> >
> > mkpasswd -d -l | tee /etc/passwd
> >
> > which will let you see it spitting out entries one-by-one as the
> > server sends responses.

Roy, the name after the "tee" command is, of course, the name of the file
you'll be overwriting.  In any case, you might want to first get a command
running (without any redirection or pipes), and then redirect it in the
way I showed you.

> > > You could try running "net user nlwiso" to find out the group
> > > membership (though I'm not certain how to ensure that the user being
> > > queried is EMEA\nlwiso);
> >
> >   "net user EMEA\nlwiso".  It's pretty universal in 'doze that
> > wherever you can put a username, you can put a DOMAIN\user string
> > instead.

Dave, you can be sure I've tried the obvious before posting.  It didn't
work for me.  Perhaps the "local domain" (i.e., the current computer)
isn't handled in the same way.

> I agree that Symantec are a bit of satanic
> corporation, but ... well, Ghost2003 is actually very
> impressive most of the time (apart from breaking
> cygwin which is a big problem of course).

It would have broken other apps as well, just not in such an obviously
detectable way.

> ok, I've fixed symantec by taking out the 2 " in the
> path and I fixed the cygwin1.dll (it was a copy of
> testdisk that was in there. testdisk carries it's own
> old version of cygwin1.dll around with it) then I did
> the mkpasswd and mkgroup stuff as you suggested ...
> and this is what I got, but I've no idea what tee it
> telling me (now I'm on my home system which is non
> domain, my office ABN Amro system is all the
> EMEA\nlwiso stuff).

"tee" isn't telling you anything, you're seeing the output of "mkpasswd"
(or "mkgroup", as the case may be).

> This is a lot confusing to me, do you understand this output ?

See <>.

> oh, after this, I still get the same error unfortunately.
> C:\cygwin>cygwin
> Your group is currently "mkpasswd".  This indicates that
> the /etc/passwd (and possibly /etc/group) files should
> be rebuilt.
> See the man pages for mkpasswd and mkgroup then, for
> example, run
> mkpasswd -l [-d] > /etc/passwd
> mkgroup  -l [-d] > /etc/group
> Note that the -d switch is necessary for domain users.

The commands you quoted will have destroyed your /etc/passwd completely.
Try re-running the commands I gave you.

> Boss@raid ~
> $ mkpasswd -d -l | tee /etc/passwd
> mkpasswd (731): [2453] Could not find domain controller for this domain.

This is a problem.  Are you on the network when you run this command?  If
not, the delay may be mkpasswd waiting for domain controller connections
to time out.

Did you run "mkpasswd -c -l", like I told you?

> Boss@raid ~
> $ mkpasswd  -l | tee /etc/passwd

This just overwrote /etc/passwd generated in the previous run.

> Boss@raid ~
> $ mkgroup  -l | tee /etc/passwd

Ditto, and this time it's with the output of mkgroup.

> Boss@raid ~
> $ mkgroup  -l -d | tee /etc/passwd
> Cannot get PDC, code = 2453

As you see, the primary domain controller is inaccessible.  Do you need to
be on a VPN or something to log in to the domain?
      |\      _,,,---,,_
ZZZzz /,`.-'`'    -.  ;-;;,_
     |,4-  ) )-,_. ,\ (  `'-'		Igor Pechtchanski, Ph.D.
    '---''(_/--'  `-'\_) fL	a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!

"The Sun will pass between the Earth and the Moon tonight for a total
Lunar eclipse..." -- WCBS Radio Newsbrief, Oct 27 2004, 12:01 pm EDT

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list