mcedit stackdumps

Christopher Faylor
Fri Jun 10 16:15:00 GMT 2005

On Fri, Jun 10, 2005 at 04:47:37PM +0200, Krzysztof Duleba wrote:
>For a few months now I've been suffering from mcedit internal error. Every
>once in a while, without any reason, mcedit stackdumps during exit
>procedure (after pressing F10 or double ESC). I got this error with
>1.5.16, then with 1.5.17 snapshots, and now with 1.5.17 as well. I haven't
>tried current snapshots yet. Should I?
>Debugging mcedit seems pointless as stackdumps occur on a very irregular
>basis. Can I provide any more information?
>I believe this might have something to do with Cygwin because:
>- similar version of mcedit works fine on a Linux box
>- before 1.5.16 (or 1.5.15, I'm not sure about that) Cygwin version worked
>fine as well
>$ mcedit --version
>GNU Midnight Commander 4.6.1-pre2a
>$ uname -a
>CYGWIN_NT-5.0 duli2 1.5.17(0.129/4/2) 2005-05-25 19:38 i686 unknown
>unknown Cygwin
>$ cat mc.exe.stackdump
>Exception: STATUS_ACCESS_VIOLATION at eip=610CA032

This is indicative of a malloc corruption problem.  It is probably a problem
with mcedit itself, not cygwin.


Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list