sshd and /usr/bin/zsh

Corinna Vinschen corinna-cygwin@cygwin.com
Tue Jun 21 23:35:00 GMT 2005


On Jun 21 15:59, Martin Vetter wrote:
> hi,
> 
> >>-  zsh as login shell for non-administrator = login via sshd hangs (!)
> >>- bash as login shell for non-administrator = login via sshd works 
> >>fine
> >>-  zsh as login shell for the administrator = login via sshd works 
> >>fine
> >>workaround: use cygwin1.dll release 1.5.14,
> >
> >There's a far better way:
> >Go a step forward instead of three steps back.
> >Try the latest snapshot from http://cygwin.com/snapshots/.
> >I just tried to use zsh as login shell
> >from an ssh session and guess what? It works.
> 
> i tried it, but cygwin1-20050617.dll doesn't work, too.
> 
> btw, the unsuccessful login via zsh produces a error message window:
> "zsh.exe - Application Error: The application failed to
>  initialize properly (0xc0000022). Click OK to terminate the 
> application."

I can't reproduce the error box, but I could reproduce the hang.
I think I've tracked it down to a permission problem when creating
a pipe after starting the new process under another, non-privileged
user account.  I've applied a patch which solved the zsh hang for
me.  Please try the latest snapshot (2005-Jun-21) from
http://cygwin.com/snapshots/.

[Oh and, please ignore the fact that the tar archives of the latest
 snapshot is different from all other snapshots.  Thanks.]


Corinna

-- 
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          mailto:cygwin@cygwin.com
Red Hat, Inc.

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list