Cygwin xfig eps problem

m shi
Sat Oct 1 13:56:00 GMT 2005

Hi Franz - Thanks very much for replying to my post.

Franz Haeuslschmid <lukrez <at>> writes:
> I'm also affected by this problem.  I know, that "Me too" posts
> are evil, but I think, it may by useful to point out older
> threads and messages that were discussing this sort of problem.
> My article can be found in the mailing list archives discussing
> XFree:

Well, I don't necessarily think they are "evil", if for no other reason than it
might get some useful dialogue going. Yes I had seen those previous posts, as
well as a couple of others. I had, in fact, considered replying to your post
instead of starting a new thread since it seemed the closest to the problem I'm

>From what I've read, there do seem to be a couple of minor variations on a theme

1. Your post does not mention being able to successfully (with preview) import
the first eps file that you try in a given xfig session. Are you able to? I was
initially not able to, until I changed my system temp path (BOTH windows and
cygwin) to a directory without spaces in the complete path (instead of windows'
ridiculous default location in "\Documents/ and/ Settings"

2. The other post you mention describes gs from the command line not liking a
/tmp path for -sOutputfile. I have tried from the command line, and my gs
outputs fine to /tmp (which is the manner in which xfig appears to refer to the
file). I have tried the scripts proposed by Igor in that thread, (with both
cygwin's gs and gswin32c) and they do not change the behavior I am seeing.

I think it does have something to do with file permissions - perhaps the gs
spawned by xfig has a user that our systems do not know anything about (but
which exists by default on *nix systems), and therefore the .pix file is somehow
invalid. Are you using NTFS for the partition containing your /tmp directory?
Perhaps also it only affects installations using NTFS since other windows
filesystems don't care about security so much, and perhaps that is why not
everyone sees the same behavior? (Just speculating here.) I use XP Home, so I do
not have a "Security" tab unless I use safe mode - maybe I'll try that now to
see if I can get any more information.
> My "solution" at that time was to ignore the error messages and
> to do without the preview.  I could use the presented bounding
> box of the imported object to estimate size and position of the
> imported EPS figure.
> Regards,
> Franz.

Agreed - this works, and it is of course only the preview that is missing.
(Although I can always get 1 eps file per xfig session with preview correctly
which is ok for a majority of situations.) Another "solution" is to use epstool
to convert eps => fig. It works surprisingly well (quality-wise), but it does
make the task of maintaining graphics for documents one step more complex.

Thanks again for your reply, and would be interested to here on whether your
problem is identical to mine, or slightly different. Cheers,

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list