question about sshd hang during rexec

jhdiuad jhdiuad
Sat Oct 1 18:03:00 GMT 2005

Hi, sshd appears to hang after rexec() when I try to
I am running sshd version OpenSSH_4.2p1 on windows
If I run /usr/sbin/sshd -dddD -r it works OK.
I have tried mv'ing the /usr/sbin/sshd to a tempfile
and replacing it with another program and that program
does get executed. Also I wrote a small program to
test rexec() and it does appear to be working.  I am
using the default sshd_config and ssh_config files
created by ssh-host-config. I've tried installing
cygwin from scratch and it doesn't fix the problem.
Any help would be appreciated. 

$ /usr/sbin/sshd -dddD
debug2: load_server_config: filename /etc/sshd_config
debug2: load_server_config: done config len = 187
debug2: parse_server_config: config /etc/sshd_config
len 187
debug1: sshd version OpenSSH_4.2p1
debug1: private host key: #0 type 0 RSA1
debug3: Not a RSA1 key file /etc/ssh_host_rsa_key.
debug1: read PEM private key done: type RSA
debug1: private host key: #1 type 1 RSA
debug3: Not a RSA1 key file /etc/ssh_host_dsa_key.
debug1: read PEM private key done: type DSA
debug1: private host key: #2 type 2 DSA
debug1: rexec_argv[0]='/usr/sbin/sshd'
debug1: rexec_argv[1]='-dddD'
debug2: fd 3 setting O_NONBLOCK
debug1: Bind to port 22 on
Server listening on port 22.
Generating 768 bit RSA key.
RSA key generation complete.
debug1: fd 4 clearing O_NONBLOCK
debug1: Server will not fork when running in debugging
debug3: send_rexec_state: entering fd = 7 config len
debug3: ssh_msg_send: type 0
debug3: send_rexec_state: done
debug1: rexec start in 4 out 4 newsock 4 pipe -1 sock

[ just hangs here ]

Yahoo! Mail - PC Magazine Editors' Choice 2005

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list