ssh tunnel and permission denied

Leonard Bouchet
Thu Oct 13 08:39:00 GMT 2005

On 13 oct. 05, at 00:30, Brian Dessent wrote:

> Leonard Bouchet wrote:
>> # Step 1: open the ssh tunnel
>> $ ssh -fNL 139:myserver:139 user@myserver
> I'm surprised that this works.  Normally if you try this on a windows
> machine the port forwarding setup will fail because the local SMB
> service on that machine is already listening on 139, and so it's
> impossible for ssh to bind to that port.  How are you getting around
> this?  Have you tried adding verbosity (-vvv) to the ssh command to see
> if there are errors setting up the port forwarding?

I'm simply not sharing anything on the W98 box. On the XP box where I 
need the sharing facility, I'm planning to add a loopback card with 
another ip (procedure found here: 
<>). Don't know 
yet how I will bind the forwarding to that network through cygwin, 

I'm quite sure the port forwarding works, though, because:

1. I tried to add verbosity, and it seems that everything is ok
	debug1: Authentication succeeded (publickey).
	debug1: Local connections to LOCALHOST:139 forwarded to remote address 
	debug3: channel_setup_fwd_listener: type 2 wildcard 0 addr NULL
	debug1: Local forwarding listening on port 139.
	debug2: fd 4 setting O_NONBLOCK
	debug3: fd 4 is O_NONBLOCK
	debug1: channel 0: new [port listener]

2. My lmhosts entry for 'myserver' is set to and I can't get 
the next step to work if I don't forward the port according to step 

Any idea on what it's going on?

Thanks a log,

-leonard bouchet

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list