Problems opening files from run menu

Paminu fedevaps@yahoo.dk
Wed Oct 19 15:28:00 GMT 2005


"Christopher Faylor" <cgf-no-personal-reply-please@cygwin.com> skrev i en 
meddelelse news:20051019145018.GD3521@trixie.casa.cgf.cx...
> On Wed, Oct 19, 2005 at 04:38:43PM +0200, Paminu wrote:
>>I have a xfig file in:
>>
>>c:\cygwin\home\test\test.fig
>>
>>I can open this xfig file from the run menu like:
>>bash --login -e startxprog xfig c:/cygwin/home/test/test.fig
>>
>>I also have a .dvi file in:
>>c:\cygwin\home\test\test.dvi
>>
>>But when I type:
>>bash --login -e startxprog xdvi c:/cygwin/home/test/test.dvi
>>
>>Nothing happens. Why is it possible to open a file like this with xfig but
>>not with xdvi???
>
> How about using UNIX-like paths rather than Windows paths, that being
> one the main reasons for Cygwin's existence?
>
>  bash --login -e startxprog xdvi /home/test/test.dvi


That works fine. But the problem is when I execute xdvi from emacs. Then 
this gets inserted:
c:/cygwin/home/test/test.dvi

if I could just get emacs to only type /home/test/test.dvi it would work.

But I think it is wierd that xfig accepts the full path while xdvi only 
accept the path excluding c:/cygwin, but maybe its a bug in xdvi. 




--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list