Cron Problems with Cygwin

CWS Informatics [Sas] scoop@EC.GC.CA
Fri Oct 21 17:06:00 GMT 2005

I am having trouble getting the cron to run properly under Windows 2000
and XP with cygwin.

I have searched through several threads on the mailing list, including
these most relevant ones:
The solutions did not overly work, although they did help me progress a
little bit.

The service appears to install and start with no problems.
The crontab files are correct and the cron service is running my tasks
as I had set them. For example, I have a task set to run eveyr 5
minutes, and I see an event in the event viewer every 5 minutes saying
"CMD (/home/test/test)" as part of it; this is indeed the what I was
trying to run every 5 minutes (just a test).
However, nothing happens. The command is supposed to be a script that
does a bunch of other stuff (for testing it simply append echoes the
time to a file), but it never happens. If I run the script just from the
command line it works fine.

The events are running as SYSTEM at least the event viewer shows them as
All associated cron files are owned by system.
I have tried changing the permissions and modes of some of the files as
mentioned in the above threads - no difference.

The full text of the event log entry for the task being run is:
The description for Event ID ( 0 ) in Source ( /usr/sbin/cron ) cannot
be found. The local computer may not have the necessary registry
information or message DLL files to display messages from a remote
computer. You may be able to use the /AUXSOURCE= flag to retrieve this
description; see Help and Support for details. The following information
is part of the event: /usr/sbin/cron : PID 3816 : (scoop) CMD

I would appreciate any insight into what may or may not be working.

Thank you.

Chris White

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list