Cron Problems with Cygwin

CWS Informatics [Sas] scoop@EC.GC.CA
Mon Oct 24 15:39:00 GMT 2005


I am not sure what else you want based on reporting guidelines. I
attached the cygcheck file though.

As for what I am trying to do: 

We have a bunch of old Unix scripts and software that we need to keep
running for awhile. 
These need to run every x minutes for y range of hours during the day.
The scripts and software produce the results we are looking when run
from the command line in Cygwin. 

There is nothing but "Cron Started [<number>]" in the cron log.

Thank you.


-----Original Message-----
From: Larry Hall (Cygwin) [mailto:reply-to-list-only-lh@cygwin.com] 
Sent: Sunday, October 23, 2005 4:39 PM
To: CWS Informatics [Sas]
Cc: cygwin@cygwin.com
Subject: Re: Cron Problems with Cygwin


CWS Informatics [Sas] wrote:
> I am having trouble getting the cron to run properly under Windows 
> 2000 and XP with cygwin.
> 
> I have searched through several threads on the mailing list, including

> these most relevant ones: The solutions did not overly work, although 
> they did help me progress a little bit.
> 
> http://www.cygwin.com/ml/cygwin/2001-12/msg01123.html
> http://www.mail-archive.com/cygwin@cygwin.com/msg29278.html
> http://www.cygwin.com/ml/cygwin/2003-09/msg01855.html
> http://www.cygwin.com/ml/cygwin/2003-09/msg00803.html
> 
> The service appears to install and start with no problems. The crontab

> files are correct and the cron service is running my tasks as I had 
> set them. For example, I have a task set to run eveyr 5 minutes, and I

> see an event in the event viewer every 5 minutes saying "CMD 
> (/home/test/test)" as part of it; this is indeed the what I was trying

> to run every 5 minutes (just a test). However, nothing happens. The 
> command is supposed to be a script that does a bunch of other stuff 
> (for testing it simply append echoes the time to a file), but it never

> happens. If I run the script just from the command line it works fine.
> 
> The events are running as SYSTEM at least the event viewer shows them 
> as SYSTEM. All associated cron files are owned by system.
> I have tried changing the permissions and modes of some of the files
as
> mentioned in the above threads - no difference.
> 
> The full text of the event log entry for the task being run is: The 
> description for Event ID ( 0 ) in Source ( /usr/sbin/cron ) cannot be 
> found. The local computer may not have the necessary registry 
> information or message DLL files to display messages from a remote 
> computer. You may be able to use the /AUXSOURCE= flag to retrieve this

> description; see Help and Support for details. The following 
> information is part of the event: /usr/sbin/cron : PID 3816 : (scoop) 
> CMD (/home/test/test).
> 
> I would appreciate any insight into what may or may not be working.


Please read and follow the problem reporting guidelines found at:

> Problem reports:       http://cygwin.com/problems.html

Configuration information and details of what you're doing would also be
helpful.

You may find more info in '/var/log/cron'.

-- 
Larry Hall                              http://www.rfk.com
RFK Partners, Inc.                      (508) 893-9779 - RFK Office
838 Washington Street                   (508) 893-9889 - FAX
Holliston, MA 01746
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck.out
Type: application/octet-stream
Size: 13272 bytes
Desc: cygcheck.out
URL: <http://cygwin.com/pipermail/cygwin/attachments/20051024/dc329803/attachment.obj>
-------------- next part --------------
--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/


More information about the Cygwin mailing list