Variation on: regular user, bash cannot find /tmp

David LaFrance-Linden
Tue Sep 5 05:15:00 GMT 2006

I found a few similar problems in your mail archives, but I did not quickly
find the problem I'm having.  Attached is cygcheck output as requested.

A few days ago, as a normal user on my MS Windows box, I went to
and ran setup.exe to install things, for "just me".  Everything seemed to go
OK.  When I ran the shortcut, it brought up a bash.  First time up it did
some setup.  Things worked.

Then I decided to install it for everyone.  I deleted all the cygwin stuff I
could find from my directories.  Then, from an Admin account, I went to again, ran setup.exe again, and chose "For everyone" and put
things under c:\cygwin.

Again, everything seemed to go OK.  But when I, as the original user, try
the newly installed shortcut on my desktop, I get 

    bash.exe: warning: could not find /tmp, please create!

complaint.  The other reports I found seem to indicate it gets further than
I get.

At first, I thought the entire installation must have gone south, somehow.
But... if I login as a different (and non-admin) user, the first time I
click on the Cygwin shortcut on that different user's desktop, it does its
first-time bash setup and works.

I've been trying to find some file or some shred of data that got left over
and undeleted from my first (and personal) installation that could be
polluting or distracting the for-everyone installation.  

I've tried running the batch commands by hand from a command shell, with the
same result.  Is there an option to bash to have it dump out a lot more of
what it is doing.  I already tried -v.

`pwd` indicates I'm in /usr/bin.  But no commands seem to work.  

`echo ~` indicates I'm in my Windows homedir, not my cygwin homedir, and
this is a difference with the other users.  But how and/or why?  And how to
I fit it?

I can't seem to run any non-builtin program; I always get file not found,
even with explicit pathnames, absolute and relative to `pwd`.

I was able to do `set > ~/foo.txt` from as me (David) and have attached that
as well.

Also attached (the ...2 versions) are the cygcheck and set from a user that
works.  Maybe somebody can find the crucial difference and tell me how to
fix it?

I use Linux daily for work; my Windows skills are minimal.

Any clues?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck.out
Type: application/octet-stream
Size: 12733 bytes
Desc: not available
URL: <>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: foo.txt
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck2.out
Type: application/octet-stream
Size: 12623 bytes
Desc: not available
URL: <>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: foo2.txt
URL: <>
-------------- next part --------------
Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list