Resource Temporarily Unavailable

Nick Deubert
Mon Sep 11 15:56:00 GMT 2006

Chris McIntosh wrote:
> Hello, I work at a company where we have a complicated Linux build. We
> use cygwin to mimic this build on windows for some of our windows
> centric people.
> At different times when cygwin forks it will throw a Resource
> temporarily Unavailble error. I am tempted to call this "Random"
> because it doesn't manifest itself until a random time, but once
> manifested it will continue to fail at the exact same spot. This spot
> is different for all users but once it does happen it continues to
> fail.
> This is typically in our make flow when it is forking or spawning
> another process to execute a command.
> Here is a snip
> ../../../../..//class/mfs/engine/disp/gf100_engine.mfs
> /usr/bin/env: ../../../../..//bin/Win32/cfp: Resource temporarily 
> unavailable
> makepp: Failed to build target gf100.xml
> One thing to note, the command that it fails on is different for all
> users. It actually fails when forking. Another example is
> /usr/bin/bash: fork: Resource temporarily unavailable
> make[4]: *** [ObjWin32/.PTreeVisitor.d] Error 128
> After looking at the cygwin source I found that EAGAIN which produces
> this message is mapped to many windows errors. So after more
> investigation I found it to be Win32 error 234 which is
> ERROR_MORE_DATA. I then traced this down to when cygwin calls
> CreateProcessAsUser in
> So my question, has anyone seen this before. I don't think it is a
> cygwin bug since it the win api returning this error, but maybe it is
> something to do with the call.
> Any pointers or tips would be helpful.
Hi all,
I also have this problem. I use xfce as my desktop and window manager 
and after a totally arbitrary amount of time (sometimes 10 mins, 
sometimes days) I start getting this error "Failed to fork (Resource 
temporarily unavailable)" from the xfce4-panel and it refuses to launch 
anything. Xfdesktop usually goes shortly after as well. I also noticed 
by the time this starts happening the process stops showing up when I do 
a "ps -ef", It doesn't even show up when I pass it a -W either, I have 
to kill it from Task Manager and start a new one. About this time I also 
start repeatedly getting this exact error as well: when I build my 
companies tool in cygwin (with make-3.80).

I've reinstalled cygwin several times, tried doing a rebaseall, tried 
changing the heap size, and none of that made any difference for me. 
(Have not tried the new dll posted in this thread but it was reported 
that did not solve his problem). I tried downgrading bash from 3.1-6 to 
3.0-14 and it seemed like it had fixed both problems but then a week 
later it returned. I tried setting 
"CYGWIN=error_start=c:\cygwin\bin\gdb.exe codepage:oem" and verifyed it 
worked but it does not catch the sh.exe crash.

I use the xfce4 ports from: 
(several versions, it happened with all of them) and have also tried the 
pkgs in I had everything working 
perfectly for over a year with the xfce ports mentioned, then something 
happened to my cygwin install in a power outage so I did a clean 
reinstall. Ever since I have had all these nightmare problems. Any 
suggestions for what to try/check/install/log/debug would be greatly 

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list