Mount does not show Samba files

Larry Hall (Cygwin)
Wed Sep 13 18:01:00 GMT 2006

Arun Biyani wrote:
> Larry Hall (Cygwin) wrote:
>> Arun Biyani wrote:
>>> mwoehlke wrote:
>>>> Arun Biyani wrote:
>>>>> [download$:575] ls //goddard/y
>>>>> ls: //goddard/y: No such file or directory
>>>>> [download$:576] ls //goddard/abiyani
>>>>> ls: //goddard/abiyani: No such file or directory
>>>>> [download$:577]
>>>> Larry Hall (Cygwin) wrote:
>>>>> what does 'ls /cygdrive/y' say?
>>>> You didn't answer this, and it may be relevant. (That, or you typo'd 
>>>> in your previous message :-).)
>>> I have mapped mounted drives to "/" (mount -c /).
>>> [doc$:598] ls /y
>>> ls: /y: No such file or directory
>>> [doc$:599] ls /cygdrive/y
>>> ls: /cygdrive/y: No such file or directory
>>> [doc$:600]
>> Then I'd say there's a pretty good chance you don't have access to this
>> network share.  Does it require authentication?
> I mount it using this command
> net use y: \\\\goddard\\abiyani $PD /USER:abiyani
> I can umount it. Go to "My Computer". When I click on this drive, I 
> cannot see the contents. Then
> in Cygwin, I run the above command. Cygwin still won't let me see the 
> contents but Windows does.
> Definitely looks like the mount command worked.

Right.  That looks good.  Hm, I'm not sure why you don't see anything.
Is it any different if you do 'ls //goddard/abiyani' without the 'net
use' (and Cygwin mount)?

What does 'cacls y:' say?

Reviewing your cygcheck output again, the only things I see "wrong" that
you might try are:

   1. Upgrade your installation or at least the cygwin package.

   2. Remove "CYGWIN=nontsec" from your environment, stop all Cygwin
      processes and then try starting bash again and do 'ls //goddard/abiyani'
      again.  It's possible there is a permissions type problem that's being
      incorrectly reported as a "No such..." error.  But I'm grasping a bit

Larry Hall                    
RFK Partners, Inc.                      (508) 893-9779 - RFK Office
216 Dalton Rd.                          (508) 893-9889 - FAX
Holliston, MA 01746

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list