Mount does not show Samba files

Larry Hall (Cygwin) reply-to-list-only-lh@cygwin.com
Wed Sep 13 19:53:00 GMT 2006


Arun Biyani wrote:
> Larry Hall (Cygwin) wrote:
>> Arun Biyani wrote:
>>> Larry Hall (Cygwin) wrote:
>>>> Arun Biyani wrote:
>>>>> mwoehlke wrote:
>>>>>> Arun Biyani wrote:
>>>>>>> [download$:575] ls //goddard/y
>>>>>>> ls: //goddard/y: No such file or directory
>>>>>>> [download$:576] ls //goddard/abiyani
>>>>>>> ls: //goddard/abiyani: No such file or directory
>>>>>>> [download$:577]
>>>>>>
>>>>>> Larry Hall (Cygwin) wrote:
>>>>>>> what does 'ls /cygdrive/y' say?
>>>>>>
>>>>>> You didn't answer this, and it may be relevant. (That, or you 
>>>>>> typo'd in your previous message :-).)
>>>>>>
>>>>> I have mapped mounted drives to "/" (mount -c /).
>>>>>
>>>>> [doc$:598] ls /y
>>>>> ls: /y: No such file or directory
>>>>> [doc$:599] ls /cygdrive/y
>>>>> ls: /cygdrive/y: No such file or directory
>>>>> [doc$:600]
>>>>
>>>> Then I'd say there's a pretty good chance you don't have access to this
>>>> network share.  Does it require authentication?
>>>>
>>> I mount it using this command
>>> net use y: \\\\goddard\\abiyani $PD /USER:abiyani
>>>
>>> I can umount it. Go to "My Computer". When I click on this drive, I 
>>> cannot see the contents. Then
>>> in Cygwin, I run the above command. Cygwin still won't let me see the 
>>> contents but Windows does.
>>> Definitely looks like the mount command worked.
>>
>>
>> Right.  That looks good.  Hm, I'm not sure why you don't see anything.
>> Is it any different if you do 'ls //goddard/abiyani' without the 'net
>> use' (and Cygwin mount)?
>>
>> What does 'cacls y:' say?
>>
>> Reviewing your cygcheck output again, the only things I see "wrong" that
>> you might try are:
>>
>>   1. Upgrade your installation or at least the cygwin package.
>>
>>   2. Remove "CYGWIN=nontsec" from your environment, stop all Cygwin
>>      processes and then try starting bash again and do 'ls 
>> //goddard/abiyani'
>>      again.  It's possible there is a permissions type problem that's 
>> being
>>      incorrectly reported as a "No such..." error.  But I'm grasping a 
>> bit
>>      here.
>>
> Thx, Larry. Transcript below. I & S are network drives also. I don't see 
> Y in the
> df output but its there in "My Computer". My cygwin installation is 
> uptodate. Cygcheck
> output attached. I have not defined CYGWIN=nontsec. Where is this 
> defined anyway?

See your cygcheck output:

CYGWIN = 'nontsec'

This must be set in your environment somewhere.  Possibly this is introduced
by Altera tools Dave mentioned (thanks Dave).  If you don't know why it's set,
find it and remove it.  Alternatively, if you cannot find it for some
reason, at least unset it in your cygwin.bat file (assuming you start Cygwin
that way).  This is a cheap hack though.  You're better off removing the
setting for real.

Your cygcheck says you have cygwin package version 1.5.19-4.  The current
version is 1.5.21-2.

I think you're getting a conflicts between Altera and Cygwin.  Removing Altera
is likely not the solution to the problem you see but it will avoid other/
future problems.  The solution to your current problem is to regenerate your
passwd/group files, as Dave mentioned.  At least this should work if your
user and the resource available are in the same domain.

-- 
Larry Hall                              http://www.rfk.com
RFK Partners, Inc.                      (508) 893-9779 - RFK Office
216 Dalton Rd.                          (508) 893-9889 - FAX
Holliston, MA 01746

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list