completion-ignore-case problem with cygwin

Eric Blake
Fri Sep 15 11:44:00 GMT 2006

Hash: SHA1

Ugh - reformatted.

> -----Original Message-----
> From: Igor Peshansky []
Ugh - spam feeder.

> Yes, it definitely seems to be turned off.  Are you sure your ~/.inputrc
> gets read?  Is your HOME variable set correctly?
> Try running 'bash -vx --login -i' to see what commands are executed when
> you run a login shell.  Perhaps there is a startup script somewhere that
> executes the bind command to turn completion-ignore-case off.
> HTH,
> 	Igor

According to Levy, Bruce on 9/14/2006 4:40 PM:
> Hi Igor,
> Thank you very much for your reply.
> I invoked 'bash -vx --login -i' and watched the commands that were being
> executed.  I did NOT see any reference to completion-ignore-case.
> Should I see the lines in .inputrc being executed?  I did not see any
> .inputrc output.

The sourcing of ~/.inputrc will not show up in the bash trace.  If you are
desparate, you can use strace to see what files bash sources, but the
output is quite long and should not be posted here without an explicit

> From my bash shell I ran bind 'set completion-ignore-case on' and that
> worked perfectly.  I then tried putting that line into .bashrc and that
> also worked.  So, I have a workaround, but I'm not sure why .inputrc is
> not invoked.

Igor's question about HOME is important - are you changing $HOME inside of
your .bashrc?  It could be that bash IS attempting to source ~/.inputrc,
but at a time when ~ is incorrectly set.  You can also set the INPUTRC
environment variable (prior to bash's execution) to tell bash to look
somewhere else, to ensure that your file is picked up during readline

- --
Life is short - so eat dessert first!

Eric Blake   
volunteer cygwin readline maintainer
Version: GnuPG v1.4.2.1 (Cygwin)
Comment: Public key at
Comment: Using GnuPG with Mozilla -


Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list