cron - error starting a service

David Rekas
Wed Sep 20 07:55:00 GMT 2006


I have installed cron-3.0.1-19 within CYGWIN_NT-5.1 1.5.21(0.156/4/2) on
my Win XP 5.1.2600 machine. Configured it with recommended settings and
attempted to start the service, however the notorious error came up:

cygrunsrv: Error starting a service: QueryServiceStatus:  Win32 error
The service has not been started.

Since have searched for and tried many solutions available on the net,
but the same error persists.

Here is a run down of what I've tried so far (the reinstallation of the
service was performed after each fix was tried). 

If there is anything that I've missed, I would really appreciate your

# Used 1.8 repeatedly until it no longer found any
# Edited cron-config: enclosed any relavent lines of code which contain
"${USER}" and "$cron_table" in double quotation marks, as these may
contain spaces.
$ mkpasswd -l > /etc/passwd
$ mkpasswd -d -u "$USER" >> /etc/passwd
$ mkgroup -l > /etc/group
$ mkgroup -d -g "Domain Users" >> /etc/group
$ crontab -e
$ chgrp "SYSTEM" "/var/cron/tabs/$USER"
$ chgrp "SYSTEM" /var/run
$ chgrp "SYSTEM" /usr/sbin/cron
$ chgrp "SYSTEM" /usr/sbin/sendmail
$ chmod 640 "/var/cron/tabs/$USER"
$ chmod +x /bin/cygwin1.dll
$ rm -R /etc/cron.d
$ mkdir /etc/cron.d
$ chmod 777 /etc/cron.d

# Config
$ cron-config   // answer: [service: yes; yourslef: no; ntsec: yes]

# Reinstall
cygrunsrv --stop cron
cygrunsrv --remove cron
cygrunsrv --install cron -p /usr/sbin/cron -a -D
cygrunsrv --start cron

# Added SYSTEM to group 544 via the /etc/group
# Attempted to delete /var/run/, however it DID NOT exist
# Attempted to check /var/log/cron.log, , however it DID NOT exist
# Checked windows event log it contains the following message each time
cron was attempting to start:
   The description for Event ID ( 0 ) in Source ( cron ) cannot be
found. The local computer may not have the necessary registry
information or message DLL files to display messages from a remote
computer. You may be able to use the /AUXSOURCE= flag to retrieve this
description; see Help and Support for details. The following information
is part of the event: cron: PID 3532: `cron' service stopped, exit
status: 128.

Attached: crontab.txt and cygcheck.txt



-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: crontab.txt
URL: <>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: cygcheck.txt
URL: <>
-------------- next part --------------
Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list