cywin/x issues

Tue Sep 26 21:36:00 GMT 2006

I have a client who has some gui applications running on a linux box.  I am
running MS Windows locally, so someone recommended that I try using cygwin.

I installed the following packages this morning: 1) the entire base package
2) the entire x11 package 3) the inetutils and openssh packages (since I
want to use ssh to connect to the remote machine).  Basically, I followed
the instructions here:

To ssh into the remote machine, I simply tried the included dos script

And once the xwin shell came up, I executed
	ssh -X -Y -l <myUserName> <theRemoteMachineName>
and entered my password and got into the remote machine.  So far so good.

I then tried playing around withsome x apps: xclock and xlogo worked fine
(how could they go wrong?).

But then I tried executing a medium complex program, gnome-system-monitor,
and I ran into the following issues:

1) speed

The first time that I played with the gui, it was unbelievably slow, to the
point of being unusable.  For instance, clicking on the File menu took 2-3
seconds to display the menu choices (which was simply Quit in this case).

Later on in the afternoon when I played with the exact same app again, it
executed more more quickly.

Anyone have any idea why?  I am guessing that likely my network connection
(a Time Warner cable modem in NYC) was just getting a surge of traffic, or
maybe had signal strength issues or something.  Perhaps also the remote
machine was having a surge of activity at the time (I forgot to check using
top when it was problematic, my mistake).  Or maybe the first time the
program ran, it was downloading remote fonts or something that were cached
locally for subsequent executions.

I am aware that some personal firewalls are known to cause slow performance;
see, for example, some of the posts here:
I tried looking at my windows networking state with netstat but did not see
the loopback issues reported above, so I do not think that my firewall (AVG)
is the culprit.

2) warning messages

Executing gnome-system-monitor caused a ton of errors like
	** (gnome-system-monitor:30353): WARNING **: Unable load icon Failed to
open file '/usr/share/pixmaps/ssh-askpass-gnome.png': No such file or
to appear.

I also saw 3 errors like
 (gnome-system-monitor:30353): Gtk-WARNING **: Attempting to sort on invalid
type GdkPixbuf
once gnome-system-monitor is up and running.

A web search reveals that a few other people have these errors too, e.g.:

Is the reason for the above because the remote machine is using an old
version of linux?

Typing uname -a on the remote machine gave
	... 2.6.11-1.1369_FC4smp #1 SMP Thu Jun 2 23:08:39 EDT 2005 i686 i686 i386

Would FC5 cure these errors?

3) fonts

The gnome-system-monitor app simply looks horrible.  The best description
that I can give is that it looks like when you take a screen shot and then
save it as a jpeg file instead of as a png file: the text looks weird and
sorta smeared.

Did I simply fail to configure things properly?  And is there a ready cure
for the bad looking fonts?

4) XMing better?

It looks like cygwin/x has been defunct for a long while now.  In contrast,
this website
claims that the XMing program is actively developed and a lot better.

Anyone have any experience with it versus cygwin/x?
View this message in context:
Sent from the Cygwin Users mailing list archive at

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list