Install hangs

Larry Hall (Cygwin)
Thu Sep 28 02:40:00 GMT 2006

Eric Mader wrote:
> Larry Hall (Cygwin) wrote:
>> Eric Mader wrote:
>>> I found a bunch of stalled processes running "ash", "bash" and "sh". 
>>> I killed them all and rebooted for good measure. :-) When I ran 
>>> setup.exe again, it gets as far as running /etc/postinstall/ 
>>> and then stalls. The environment seems to be more-or-less working. 
>>> I've enclosed the output of cygcheck -c , cygcheck -s and 
>>> /var/log/setup.log.full.
>>> Am I good to go at this point, or is there still something that's a 
>>> little off?
>> 'hicolor-icon-theme' reports itself as incomplete but otherwise the
>> packages themselves are there.  Postinstall scripts have a purpose
>> so to the extent that you haven't run them, you may see some issues
>> with your environment.  I'd recommend trying two things that might
>> help:
>>   1. Remove '/', '/usr/lib', and '/usr/bin' as binary and rerun
>>      'setup.exe'.  See 'man mount' and the '-f' and '-b' flags
>>      for more details.
>>   2. With or without the above, go to the '/etc/postinstall' directory
>>      and run any scripts there that don't have the 'done' suffix.
>>      Once they have all run successfully, move them to the script
>>      name plus the 'done' suffix.
>> Hopefully one of these two procedures will get all your postinstall
>> scripts to run.  If that's true, you're good to go.
> I remounted '/', '/usr/lib' and '/usr/bin' as binary (I assume you meant 
> "remount" rather than "remove"?) and reran setup.exe. It ran all the way 
> to completion w/o any complaints, so I think I'm in pretty good shape.

Yes, remount.  Sorry about that.  My proofreading wasn't too good this

Cygcheck looks OK to me.  It's not immediately obvious to me why the
text mounts got in the way here but I'm glad it fixed it.  And I fear
other similar reports!

> I'm enclosing the output of 'cygcheck -svr > cygcheck.out'.
> In the process of messing around w/ the scripts in /etc/postinstall I 
> ran into a problem w/ find. In an attempt to find scripts where both the 
> '.sh' and the '.sh.done' versions existed I typed the command:
> find . -name "*.sh" -exec ls \{\}.done \;
> This caused some strange error messages, and left some stalled processes 
> running 'find' behind. (I can't run this command now because the 
> successful run of setup.exe cleaned them all up, but here's the output 
> of a similar use of '-exec' in find:
> $ find . -name "*.sh.done" -exec ls \{\} \;
>     197 [main] find 16764 fhandler_dev_zero::fixup_mmap_after_fork: 
> requested 0x
> 430000 != 0x0 mem alloc base 0x430000, state 0x2000, size 1040384, Win32 
> error 4
> 87
>     543 [main] find 16764 c:\cygwin\bin\find.exe: *** fatal error - 
> c:\cygwin\bi
> n\find.exe: *** recreate_mmaps_after_fork_failed
> It takes quite a long time to get a command prompt back after these 
> error messages, and it leaves behing a stalled process.
> Is this releated somehow to my many failed attempts to run setup.exe, or 
> is it a know problem w/ find?

Could be a rebase issue.  Try installing the package, read the README, and
follow the instructions for rebasing your system.

Larry Hall                    
RFK Partners, Inc.                      (508) 893-9779 - RFK Office
216 Dalton Rd.                          (508) 893-9889 - FAX
Holliston, MA 01746

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list