Problems with GMP in latest Cygwin

William Hart
Thu Sep 28 14:16:00 GMT 2006

I seem to be having some problems with the GMP library
in the latest version of Cygwin. I just installed the
latest Cygwin along with the latest GMP, however C
code that previously worked with GMP+Cygwin no longer

To try and determine whether this is a Cygwin problem
or not, I recompiled the earlier version of GMP (that
worked previously) on the latest version of Cygwin and
it doesn't fix the problem. 

The problems are strange. The gmp_printf and gmp_scanf
functions do not appear to work correctly (the former
not at all, the later does not wait for input).

For some reason there is also an obscure error which
causes programs to hang just before they finish. The
console also does not respond to CTRL-C as it used to.
I have checked that the my code works correctly with
the old version of Cygwin + GMP (4.1.x).

Another possibility is a conflict with the hardware I
am using. The new version of Cygwin is installed on my
Athlon 64 Dual Core 3800+ running Windows XP 32 bit
version. The old version is installed on my Athlon
2000+ laptop.

One possibility would be to try installing the old
version of Cygwin on my new machine to see if the
problem goes away. Is there a way of doing this?

I do not want to install the new version of Cygwin on
my laptop as I am using it to do some development
which must be completed by Oct 1st, thus I cannot risk
screwing it up.

Thanks in advance for any help.



Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list