Rebase issues with cygwin RMagick

Bjarne Christiansen
Tue Apr 17 11:32:00 GMT 2007

Hi guys,
I have created a simple rmagick  ruby script, which works fine, but
when I get to get input from wxcocoadialog (a gui dialog) I run into
the "good" old "unable to remap" issue. I'm usually able to fix these
kind of issues by doing a rebaseall, but not this time :-( I have also
tried to reinstall cygwin, imagemagick and rmagick, but nothing seems
to help. The script worked fine a couple of weeks ago, so I'm assuming
that it's caused by a recent cygwin update(?)

It seems that the --enable-auto-image-base flag has been set for ruby
and imagemagick...

Here is the error I'm getting:
    8374 [main] ruby 3516 C:\cygwin\bin\ruby.exe: *** fatal error -
unable to remap C:\cygwin\lib\ruby\site_ruby\1
.8\i386-cygwin\ to same address as parent(0x3A000) != 0x1C980000
      5 [main] ruby 5524 fork: child 3516 - died waiting for dll
loading, errno 11
1192542 [main] ruby 884 C:\cygwin\bin\ruby.exe: *** fatal error -
unable to remap
C:\cygwin\lib\ruby\site_ruby\1.8\i386-cygwin\ to same
address as parent(0x3A000) != 0x1C980000

Here is some exmple code for reproducing the problem (I'm just
executing notepad here, it could be any gui app...):

 require 'RMagick'
 app = `notepad`

Here is the sw versions in my set up:
  cygwin (1.5.24-2)
 libMagick-devel (
 ruby (1.8.5-3)
 rmagick (1.15.5)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck.out
Type: application/octet-stream
Size: 41633 bytes
Desc: not available
URL: <>
-------------- next part --------------
Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list